My particles are not fully touching my object!

Discussions about the use of Realflow
Post Reply
grigorei_rasputin
Posts: 1
Joined: Mon Oct 07, 2019 6:55 pm

My particles are not fully touching my object!

Post by grigorei_rasputin » Mon Oct 07, 2019 7:31 pm

Hey all,

I'm having a little problem in using RF for C4D.

I have set up an emitter to fill my little "concrete pool" object with particles. The particles are filling the pool, but they are not fully touching the sides and surfaces of the pool object. There is a gap between my particles... and the colliding mesh object (the pool).

What is causing this? How can I fix it such that the particles very neatly touch the surfaces of my mesh collider object?

Thanks in advance, ras

Forester
Posts: 153
Joined: Mon Mar 15, 2010 4:36 am
Contact:

Re: My particles are not fully touching my object!

Post by Forester » Tue Oct 08, 2019 5:36 pm

Apologies, I'm not a C4D user, but the answer should be in the Cell Size of the Volume for your concrete pool object.

Realflow works by creating a grid of cubic "volumes" or "cells" around your object, and then calculating the movements of the particles within those cells. You can control the size of the cells. If the cell size is relatively large, the simulation will move quickly. The smaller the cell size, the more exact the particle movements must be, and the simulation speed drops accordingly.

So, Realflow sets up a moderate-size cell as a default for all Objects, and for this moderate-sized cell, the particles rarely touch the sides of the object. (They are still colliding in an accurate manner, but it is as if the surface of the object is projected outward a bit.) To get the particles to touch, you must decrease the cell size, knowing that you will be slowing down the speed of the simulation, as a consequence. So, look for a cell size setting for your concrete pool object, and decrease that.

Not knowing C4D, I don't know whether there are both a Cell Size setting and a "Surface Offset" setting for objects. But if there are, you should give the Surface Offset setting a value that matches whatever value you give to the Cell Size settings. T(he Surface Offset setting is one useful way to ensure there is no interpenetration of particles with the walls of the object when the overall cell size is moderate or small.)

One other thing to consider is the Mesher, if you are going to make meshes of the water in your concrete pool. (If you are just making particles and rendering those particles in C4D, you can skip this part.) The Mesher, in throwing a mesh around a cloud of particles can also add or subtract volume. So, for some projects, if I am making a series of meshes of my particles in order to use a fancy shader on them (one for each step or frame of the simulation), I tend to use a Cell Size setting that leaves a little gap between my object's walls and the particles because I am likely to set the Mesher in such a way that it ends up filling that gap exactly. That is, perhaps I need to adjust the polygon size of the Mesher to give a detailed image, or I need to add a smoothing filter or a eroding filter to the Mesher. If I play with any of these settings, the Mesher may slightly add volume to the particles or it may subtract overall volume. So, I need to make a short test simulation, and then may need to adjust the Object's Cell Size Setting to account for the final result of the Mesher.
Windows 7 Pro 64 - Realflow 10.1.2.0162 (Nov 2017 patched) Standard Version

User avatar
ChristianZ
Posts: 3502
Joined: Sat Sep 09, 2006 11:37 am
Location: CH
Contact:

Re: My particles are not fully touching my object!

Post by ChristianZ » Wed Oct 09, 2019 6:25 am

Everything that Forester said!
Additionally, I can recommend another one of the "Digital Meat" tutorials, one of the few places that makes tutorials for RealFlow-C4D in addition to the documentation and short movies at Realflow.com of course.
About working with the collider tag
https://youtu.be/5rXoY1RmQFY
RF10.5 standard + RFC4D3, Mac&Windows

Post Reply

Return to “Realflow”