Two basic issues with Dyverso Particles

Showcase your finished work
herncabret
Posts: 1
Joined: Wed Dec 19, 2018 8:02 pm

Two basic issues with Dyverso Particles

Postby herncabret » Wed Dec 19, 2018 8:13 pm

Hi guys,

Fairly new to realflow, forgive the basic questions.

I am using Realflow 10.

1. Some times when I simulate with Dyverso particles it will work fine when I do a few test simulations but then randomly decide to stop working. It will quickly run through all the frames without emitting any particles. After this when I simulate it won't emit particles any more. This happens when I do little things like change small settings in the geometry. Is this a bug?

2. My particles are jumping through when simulating basic geometry. This happens even when using an open box and one dyverso emitter. What am I doing wrong here?

Any help would be great thanks.


User avatar
ChristianZ
Posts: 3469
Joined: Sat Sep 09, 2006 11:37 am
Location: CH
Contact:

Re: Two basic issues with Dyverso Particles

Postby ChristianZ » Fri Dec 21, 2018 9:21 am

Hi and welcome to the forum,

1) This might be a bug or something related to settings in that particular project. Do you have GPU acceleration activated for those sims?

2) The default quality settings are too low (the simulation preferences) for some objects. You would have to make the cells smaller of the object and use more substeps. If that does not help upload one of these scenes and I will have a look at it.
RF10.5 standard + RFC4D3, Mac&Windows

Forester
Posts: 144
Joined: Mon Mar 15, 2010 4:36 am
Contact:

Re: Two basic issues with Dyverso Particles

Postby Forester » Fri Dec 21, 2018 12:51 pm

For #1, this sounds like something inadvertant in your scene settings, and not a bug. I've been using Dyverso for years and not experienced anything like this, so I think it is not a bug in the program. Like ChristianZ, I wonder if you are using your video card (GPU) for the sim. Sometimes, certain nVidia drivers cause these kinds of problems, particularly when the driver is out of date. (For example, if you have recently updated Windows OS, but not made a similar update of your video card driver, thus creating a mismatch without intending to do so.

For Issue #2, for Dyverso, look to your Object settings. Here are the things to do, in order, for everyone that experiences this kind of issue.

# 1 - in the Object Volume settings, the Surface Offset needs to be set to something other than 0.0.
Usually, you want this set to some value that matches the Cell Size. I'm not sure why this is not set to some positive value by Default, but it always should have a setting that matches the Cell Size.

# 2 - Then, turn on "DY Continuous Collision Detection" by placing a check mark in the small box.

These two things should always be done as a matter of course for your Dyverso sims.

# 3 - If these two adjustments still do not prevent particles escaping your geometry, then you'll need to (adjust) reduce the Cell size (in your Object Volume settings). It is not uncommon to need a Cell size of "0.01". Of course, reducing your Cell Size slows down the sim.

To determine if your cell size is adequate, go to the "Display" tab in your Object's settings and click on the "Isosurface" box in the "Display Volume" area. This will turn all or parts of your object to a purple color that has some visible thickness. The purple thickness around your object is showing you the particle collision surface. If your object is completely covered in purple, you should be good to go.

But, if parts of your object are not covered (have open faces or the geometry is showing through), that is where particles will escape your geometry. Increase your object's Cell Size until your object is completely enclosed in the purple color. Then you can remove the checkmark in the Isosurface display and get back to work.

# 4 - It is possible that some particles will still escape your geometry during your sim. If they do so immediately upon running the sim, you'll now have to take the second step ChristianZ mentions, and increase the Substeps (Min and Max) of your simulation. Doing this also will slow down the sim a bit, because it is having to calculate every particle's position more frequently. But, it also will create a much more accurate simulation over all.

If you need help with the whole issue of stub-steps, you should take a look at Thomas' excellent explanation here. https://blog.realflow.com/tips/glossary ... collision/ AND here https://blog.realflow.com/tips/glossary ... n-dyverso/

Then, for further help with this issue, look for the topic in the Realflow Help section.

# 5 - If some few particles are still escaping your geometry only once in a while, while the sim is otherwise running along nicely for the most part, then you'll need to create a small "killVolume" deamon block with an "Inverse" setting checkmarked in the "No" box, and position it at the escape point on your object. These few particles have such a great force or "weight" that they're going to overcome your geometry no matter what settings you used. You could decrease the entire Cell Size one more time to eliminate them, but doing so would further slow down your entire sim. So, for the few particles that escape only once in a while, it's better to just have the killVolume deamon eat them.

# 6 - And, if you still have particles escaping, you'll need to investigate your geometry in a basic way. Do you have some face normals facing in the wrong direction, perhaps? Or missing polygon faces altogether?

Best of luck to you.
Windows 7 Pro 64 - Realflow 10.1.2.0162 (Nov 2017 patched) Standard Version


Return to “Finished Work”

Who is online

Users browsing this forum: No registered users and 1 guest