Help needed with the k age daemon!

Discussions about the use of Realflow
Microcosm
Posts: 2
Joined: Fri Aug 17, 2018 9:49 pm

Help needed with the k age daemon!

Postby Microcosm » Fri Aug 17, 2018 10:12 pm

Hey guys, first post here.

So I'm having a bit of trouble getting the k age daemon to work. I have a dyverso SPH simulation involving four fluids within a rotating cube at 60fps. The simulation is 26160 frames long and the cube's rotations are keyframed so as to be timed to music. The idea with using the k age daemon is so that after the climax of the song, the particles slowly peter out of existence over a period of 960 frames. (the last 16 seconds of the song at 60fps) I assume the best way to achieve this is using the variation value in the k age settings, where that value is measured in frames? In the past I've merely faded out a finished simulation, but I wanted to explore the use of this daemon instead.

Problem is, I just can't get it to work. I've tried a couple of variations as I'm not sure of the correct way it works:
Firstly, I've tried setting the life value to the total frame count of 26160, and then setting the variation value to 960 with the hope that the particles would start to dissipate over 960 frames before the simulation hits 26160, but in retrospect that's probably the opposite way it should work. So, secondly, I tried setting the life value to 960 frames before 26160 (so 25,200) and then setting the variation to 960 again. And thirdly, I've tried the same as the second time but with the variation set to a negative value of -960. None of the above work. I even tested it on a fresh sim just to check if I was doing it right, and the second method worked then, but it refuses to work here.

Do I have to keyframe it in somehow? The simulation has 1,013,308 particles present in it. Not sure if this has an impact or not. One thing I did wonder was whether the k age daemon only works on active emitters? I keyframed my 4 emitters to stop producing particles at the 6000th frame, after the cube had been filled.

Finally, I know that the help documentation warns against using high values in the variation value, but I have no idea what 'high' could mean in a very parametric piece of software, and I can't think of any other way of doing it.

Any help would be greatly, greatly appreciated!
AMD Threadripper 1950x 16core CPU @3.4GHz
128GB G.Skill Trident Z RAM
Nvidia GTX1080 8GB GPU
Simulating to a 2TB Samsung 960 Pro M.2 SSD
RealFlow 10


Microcosm
Posts: 2
Joined: Fri Aug 17, 2018 9:49 pm

Re: Help needed with the k age daemon!

Postby Microcosm » Sat Aug 18, 2018 5:11 pm

Anyone??
AMD Threadripper 1950x 16core CPU @3.4GHz
128GB G.Skill Trident Z RAM
Nvidia GTX1080 8GB GPU
Simulating to a 2TB Samsung 960 Pro M.2 SSD
RealFlow 10

User avatar
ChristianZ
Posts: 3374
Joined: Sat Sep 09, 2006 11:37 am
Location: CH
Contact:

Re: Help needed with the k age daemon!

Postby ChristianZ » Tue Aug 21, 2018 10:06 am

Hi and welcome to the forum,

so far I did not have problems with the k-age daemons, but I did not pay attention to its precise working. In principle it should work by kicking in when the particles have reached a certain age and that age should become affected by the variation. But maybe we have to assume that the "variation" rather randomizes the number of particles to be killed per step and not the time.
RF10 standard + RFC4D

Forester
Posts: 122
Joined: Mon Mar 15, 2010 4:36 am
Contact:

Re: Help needed with the k age daemon!

Postby Forester » Thu Aug 23, 2018 10:07 pm

whoops
Last edited by Forester on Thu Aug 23, 2018 10:17 pm, edited 1 time in total.
Windows 7 Pro 64 - Realflow 10.1.2.0162 (Nov 2017 patched) Standard Version

Forester
Posts: 122
Joined: Mon Mar 15, 2010 4:36 am
Contact:

Re: Help needed with the k age daemon!

Postby Forester » Thu Aug 23, 2018 10:16 pm

Apologies for coming late to the party.

Can I ask a dumb question? Is it not possible to simply stop the emitters at an appropriate time, so that the particles just slow down and disappear? Using keys on the emitters?

Because the normal/conventional way of stopping an emitter is to change the speed from whatever to a speed of 0.0. Using keys set on the Emitter's Speed setting. One at the beginning of the simulation that has whatever maximum speed you've worked out, and then one at a suitable step, prior to where you want it all to end, something a few steps prior to step 26160. Or, you can use three keys. One at the starting step of the simulation, and then one at somewhere like Step 26100 at the same speed as the initial speed. But at Step 26159, you have it set to a Speed of 0.0. This gives you a gradual (linear) slow-down in emission rates between Steps 26100 and 26160.

???
Windows 7 Pro 64 - Realflow 10.1.2.0162 (Nov 2017 patched) Standard Version


Return to “Realflow”

Who is online

Users browsing this forum: No registered users and 6 guests