Why are there so many little holes in my mesh?

Discussions about the use of Realflow
heisenberg
Posts: 25
Joined: Fri Mar 07, 2014 11:06 am

Why are there so many little holes in my mesh?

Postby heisenberg » Tue Mar 13, 2018 1:33 pm

Hi all,

I've been doing a test with RealFlow 10 (Hybrido). The simulation in question used around 10 million particles. I then meshed it using a fairly high particle size but I'm still getting little holes appearing everywhere in the mesh, as seen in the renders.

Any ideas? 10 million particles not enough for a simulation like this?

Here are some samples uploaded to my OneDrive account (seems there are problems uploading files to the forum):

https://1drv.ms/u/s!AsMqJZPHhEARiy02s9pCvU2pdOFs
https://1drv.ms/u/s!AsMqJZPHhEARiywDQMy59GtecxzM
https://1drv.ms/u/s!AsMqJZPHhEARiyssjc8mKBI3xk1p

Sincere thanks.


User avatar
ChristianZ
Posts: 3331
Joined: Sat Sep 09, 2006 11:37 am
Location: CH

Re: Why are there so many little holes in my mesh?

Postby ChristianZ » Wed Mar 14, 2018 4:47 pm

Hi

the large amount of particles does not avoid holes in the mesh, but it provides more detail to the fluid.
Have you used the "Hybrido mesh" or the VDB-version of the Hybrido mesh? You are not obliged to use those. You can also choose the "Particle Mesh" and manually insert (right-click) the hybrido particle emitter. This is my favorite mesh type because you have many options such as the smoothing. Then use a fairly high radius in the mesh field settings. That should help to close the holes.
RF10 standard + RFC4D, System specs: OSX 10.11, MacPro 4.1 2xXeon, GTX980Ti, 64 GB RAM

heisenberg
Posts: 25
Joined: Fri Mar 07, 2014 11:06 am

Re: Why are there so many little holes in my mesh?

Postby heisenberg » Wed Mar 14, 2018 5:00 pm

ChristianZ wrote:Hi

the large amount of particles does not avoid holes in the mesh, but it provides more detail to the fluid.
Have you used the "Hybrido mesh" or the VDB-version of the Hybrido mesh? You are not obliged to use those. You can also choose the "Particle Mesh" and manually insert (right-click) the hybrido particle emitter. This is my favorite mesh type because you have many options such as the smoothing. Then use a fairly high radius in the mesh field settings. That should help to close the holes.


Hi there,

Yes, it was the "Hybrido Mesh". I used the "Core Smoothing Filter" with a lot of steps to try and smooth the mesh.

Thanks for the tip. I will definitely use the "Particle Mesh" in future.

Many thanks. 8-)


Return to “Realflow”

Who is online

Users browsing this forum: No registered users and 1 guest