Hybrido splash particles excruciatingly slow

Anaxarchos
Posts: 843
Joined: Wed Mar 19, 2008 4:21 pm
Contact:

Hybrido splash particles excruciatingly slow

Postby Anaxarchos » Thu May 26, 2011 10:31 am

Hola Nizan,

You'd better turn off Calculate Displacement, as this might be causing your troubles.
Displacement is to be caluclated after you are fine with your basic grid fluid animation. Before adding elements like Splash or anything else.

Calculate Displacement with your Grid set to Active. Then Turn off the Calculate Displacement.

What also might be causing your long calculations is you are simulating Splash, Mist and Foam all at once.

As the calculations for those elements are interdependend, this could be slowing down your simulation a lot.

Try doing it as follows:

1) Keep your Grid in ache mode, and deactivate all Foam annd Mist Containers.

2) Simulate the Splash.

...if this simulates faster (what I think it will), after you are done with it set Splash also into cache mode and then simulate Mist. After Simulating Mist deactivate Mist (Mist isn't needed for anything but Mist) and then simulate Foam (also with Splach set to Cache).

Also, unlik Gravity from Foam. Foam is calculated due to the overall Grid Movement, adding additional Gravity will just make it sink.
www.fk-fx.com


Nizan
Posts: 45
Joined: Thu Jan 06, 2011 2:21 am

Hybrido splash particles excruciatingly slow

Postby Nizan » Thu May 26, 2011 3:25 pm

Hi Anaxarchos,

First of all - thanks.. Second - the foam is inactive.. And from what I understood from Digital-Tutors, the splash and mist need to be calculated together, because splash particles are removed when they are turned into mist. I think I might just turn it off altogether, and emit from the splash particles into maya fluids.. What do you think?

I will try both your tips, and let you know.

Thanks!

Anaxarchos
Posts: 843
Joined: Wed Mar 19, 2008 4:21 pm
Contact:

Hybrido splash particles excruciatingly slow

Postby Anaxarchos » Thu May 26, 2011 4:28 pm

Mist can be calculated as an extra process with the splashes set to cache. There is no problem with that. Let me know if my suggestions were of any help to you.
www.fk-fx.com

Nizan
Posts: 45
Joined: Thu Jan 06, 2011 2:21 am

Hybrido splash particles excruciatingly slow

Postby Nizan » Thu May 26, 2011 5:33 pm

Hi..

Still takes > 15 min per frame.. Something is really weird. Maybe something related to the geometry I'm working with? What a bummer :

Nizan
Posts: 45
Joined: Thu Jan 06, 2011 2:21 am

Hybrido splash particles excruciatingly slow

Postby Nizan » Thu May 26, 2011 5:46 pm

HURRAY!
Problem solved.. Maybe some1 will be able to benefit from this..
I imported an object from vue, which had a huge scale. I have to scale it down by a factor or 1/1000, but apparently realflow decided that a collision distance of 69 (!!) would be ok.. Well, it's not for a normal scale.
Scaled it down to 0.02, and everything works like a charm! :)

Star_Pingu
Posts: 70
Joined: Wed Mar 30, 2011 4:09 pm

Hybrido splash particles excruciatingly slow

Postby Star_Pingu » Thu May 26, 2011 6:17 pm

sometimes there are splash particles placed between grid fluid and objects that can slow down a lot the simulation.

nawka3030
Posts: 5
Joined: Fri Apr 13, 2012 5:31 pm

Re: Hybrido splash particles excruciatingly slow

Postby nawka3030 » Fri Apr 13, 2012 5:35 pm

hey man, can yoy explain more of the steps you had to take to make this simulation faster ?
did you have to rescale the whole scene ?
thanks a lot, I'm struggling with this for a while now ..

nawka3030
Posts: 5
Joined: Fri Apr 13, 2012 5:31 pm

Re: Hybrido splash particles excruciatingly slow

Postby nawka3030 » Fri Apr 13, 2012 5:46 pm

Can you explain more on what you did with the scaling ? did you have to resimulatie everything after rescaling the whole proejct ?


Return to “RF5: Fluid simulation”

Who is online

Users browsing this forum: No registered users and 1 guest