Page 1 of 1

Error on using Change resolution script

Posted: Fri Dec 24, 2010 3:18 am
by saka
I got error on using Change resolution script.

I was simulate the simple emitter on low resolution.

Emitter interpolation setting is "Global" or "Local".(Not "None")

The simulation was completed.

select emitter.

click change resolution script button.

I got the Error messages and clash RealFlow5 application.
WARNING:You have changed the fluid resolution with the "None" interpolation method.
This method neither creates nor removes particles so the fluid might become unstable afte this change.

Why do it become an error in the interpolation setting Local the Global?
Is the usage different?

This topic only change the interpolation setting "from "None".


Error on using Change resolution script

Posted: Tue Dec 28, 2010 2:26 am
by saka
I will this question by another.

Error on using Change resolution script

Posted: Thu May 19, 2011 3:35 pm
by bitSeq
OK so this error has come back to haunt me, I have never had an answer to this and cant understand why it does not work.

First I had a syntax error with the script so I removed the header and tried it again, and still it had a syntax error on line 0, strangely enough I just kept clicking on the button and eventually it worked!? haha

However the script must have a flaw in it somewhere as realflow just hangs and takes 100% of the cpu at constant.... its the first frame 5k particles from res 1 to 5

Anyone know whats going on here or even tried the script themselves?

Error on using Change resolution script

Posted: Thu May 19, 2011 4:44 pm
by bitSeq
Right I have been doing some investigation with someone who knows python and it seems that its not a problem with the script but with realflow itself, I have been getting results using this little script but as soon as it is run on a per frame basis RF crashes.

s = Scene.get()
e = s.getEmitter("Fill_Object01")

res = e.getParameter("Resolution")

e.setParameter( "Interpolation", "None" )

e.setParameter( "Interpolation","Local")


e.setParameter( "Interpolation", "None" )

Re: Error on using Change resolution script

Posted: Thu May 09, 2013 1:45 pm
by monkeyinthesun
hello.... I've been learning / following some of the examples in realflow examples (specifically the "particle shifting using a GUI"), and it seems that either the documentation is out of date or some of the methods have been depreciated or changed from the corresponding documentation in both 5 and 2012. I see that you had attempted to solve this issue, but I've not had any luck moving this further from playing with it today. When i attempt to use the method you describe in your post (viewtopic.php?f=58&t=6839#p40086), i also end up also crashing realflow (tried both in 5 and 2012). I've not had much luck finding any information on how to pro grammatically implement with python, particle shifting. Have you any suggestions / pointers... i may also be missing the point as I'm learning realflow :)