Page 1 of 1

Object Leaking Problem

Posted: Mon Nov 10, 2008 9:58 am
by janne_suhonen
I have a great problem with particles leaking trough my object. 1 circle emitter is pouring blue paint into a tank and in the middle of the tank is this invisible logo which should keep the particles away from the logos area and this way form the logo in the middle. Everything is going well and looking fine (all the way to final rendering) but one thing...

Particles are leaking trough the object and messing up the whole idea of this animation. I´ve been trying to solve this problem now for like two weeks and I can´t sleep at night when I´m thinking what is wrong with my settings. (Well not really but it´s bothering me a whole lot!)

Already tried fidling with these things:
OBJECT:
Collision distance (it helps, but then particles won´t fit to those tight places between logo walls)
Distance tolerance
Collision tolerance
Collision normal
Roughness
Temperature
Collision mode
Normal size
Normal type
Reverse normals

EMITTER:
Resolution
Density
Int.pressure
Out.pressure
Viscosity
Surface tension
Speed

PREFERENCES:
Scene scale between 0.001 - 1

Min substeps between 1 - 20000
Max substeps between 1 - 20000
Fixed substeps between 1 - 20000

Also tried different kind of export/import styles from 3ds max with realflow plugins.
Some of these things I´ve just tried because I´m desperate to get this thing working. Everything affects everything, maybe. My fluid is just perfect and I really don´t want to mess with it´s settings, but if I have to...well, I have to. By the way, the tank (cube object) is working great and there are no leaks what so ever with settings like this:
Collision distance: 0.1
Distance tolerance: 0.1
Collision tolerance: 0.1
Collision normal: inward
Friction: 0.001
Bounce: 0.25
Sticky: 0.1
Roughness: 0.001
Temperature: 100
Normal size: 0.01

So if anyone here could help me with this one. There must be some kind of way to get this simulation working. (maybe some tips for the whole workflow from 3ds max to realflow and back or something, because my problem could be as far as the 3ds max model...)

Cheers for even reading this whole post!

Attached files

Object Leaking Problem

Posted: Mon Nov 10, 2008 10:56 am
by shaun_michael
Set the subsetps up in the Options tab next to the Simulate button (Just in case you're trying to do this in the preferences).

Set them to something like 50 minimum and 333 maximum. If the leak persists, raise the minimum substeps. This'll slow the sim down but give the solver more substep calculations, and in theory make it more accurate.

Also, make sure your distance tolerance isn't larger than your collision distance.

Shaun

Object Leaking Problem

Posted: Mon Nov 10, 2008 11:04 am
by janne_suhonen
I think you helped me again. And again the solution was so simple and so obvious, but only when someone point it out. This forum is the greatest thing since internet was created!

Object Leaking Problem

Posted: Mon Nov 10, 2008 6:07 pm
by lukeiamyourfather
janne_suhonen wrote: Collision tolerance: 0.1

The collision tolerance should be zero (the default) to prevent particles from going through objects. Cheers!

Object Leaking Problem

Posted: Mon Nov 10, 2008 8:21 pm
by shaun_michael
lukeiamyourfather wrote: [quote=janne_suhonen]Collision tolerance: 0.1

The collision tolerance should be zero (the default) to prevent particles from going through objects. Cheers![/quote]
Good spot.

Shaun

Object Leaking Problem

Posted: Mon Nov 22, 2010 7:32 pm
by cs3cs3cs3
Nice read, that's the thing I don't like about RF, its obviously designed by a scientist or something, they could and should do SO SO much more to make this product more user friendly. Instad of seemingly infinate variables.

You cna litereally spend weeks tweaking and simming, and 9/10 its easier to just ask someone and they'll probably know. As this thread proves.

Object Leaking Problem

Posted: Wed Sep 14, 2011 7:59 pm
by sunny
sometimes geometry can create problem. in such case make sure your geometry has proper normals.(check in ur 3d application).

Object Leaking Problem

Posted: Wed Oct 05, 2011 11:30 am
by carolswayze
Sometime it happens that we are unable to recognize our mistake and we don't recognize them until and unless someone else make us aware about the mistake.Same thing happened with me also,I didn't set the collision tolerance to zero and was facing the problem.But now I set collision tolerance to zero and now everything is working fine.Thanks.