scene crashes realflow on load

Describe your realflow bugs
Karl Richter
Posts: 19
Joined: Fri Feb 01, 2008 5:34 pm

scene crashes realflow on load

Postby Karl Richter » Fri Feb 01, 2008 5:45 pm

I have been trying to get realflow support to address this issue the past couple of days, and was wondering if anyone here would have any clue as to why this bug happens. Here is a transcript of my correspondence with nextlimit so far:



I'm not sure that you understand my problem.

I have been working with flw scenes that function fine for simulating, saving incrementally as I go along, only to find that every scene I have saved will crash realflow on load. Not running the sim, just the act of loading the scene will cause the crash. The scenes I sent you illustrate the problem. Were you able to load the file "honey010_v10_crash.flw" that I sent? Not run the sim, just load it up? And why is it that the scene "honey010_v10.flw" will load fine until it is saved with the "bargeProxi2" attached to the "RW_Splash01" node?

I really need to know what is causing this bug, so I can at least work around the problem. I have 8 more scenes to do water sim on, and it is imperative to my work flow that I can make changes to previously saved scenes!

Thanks,
Karl

----- Original Message -----
From: "Next Limit Support"
To: ********
Cc: "Next Limit Support"
Sent: Friday, February 1, 2008 4:19:33 AM (GMT-0800) America/Tijuana
Subject: RE: Tech Desk web form client RealFlow 3897

Hello Karl,



I send you the scene without issues when you save again. There was a very bug realwave mesh doing realflow crash by memory problems, moreover, you have particles in RW Splash hitting the surface of realwave with 0.5. Less level of hitting is better because particles are going far from the limits and they are causing memory problems too.



Regards,



========================================

Check out our Maxwell FAQs and RF4 FAQs!,

the quick and easy way to solve many problems

========================================

Luis Miguel Mora

Next Limit Technologies 

www.nextlimit.com







De: *****
Enviado el: jueves, 31 de enero de 2008 18:50
Para: Next Limit Support
Asunto: Re: Tech Desk web form client RealFlow 3897



In the attached archive, you will find the sd and two flw files. The flw file "honey010_v10.flw" will load properly. However, if you add the object "bargeProxi2" to the "RW_Splash01" node and save the scene you will not be able to reopen it without realflow crashing. The file "honey010_v10_crash.flw" is an example of this.

Thanks,
Karl



----- Original Message -----
From: "Next Limit Support"
To: ********
Cc: "Next Limit Support"
Sent: Thursday, January 31, 2008 12:48:39 AM (GMT-0800) America/Tijuana
Subject: RE: Tech Desk web form client RealFlow 3897

Hello Karl





Could you send us the scene to check here? Just flw and sd files. Thanks



Regards,



========================================

Check out our Maxwell FAQs and RF4 FAQs!,

the quick and easy way to solve many problems

========================================

Luis Miguel Mora

Next Limit Technologies 

www.nextlimit.com



De: ******
Enviado el: jueves, 31 de enero de 2008 2:10
Para: techdesk@nextlimit.com
Asunto: Tech Desk web form client RealFlow 3897












Customer:client
Product: RealFlow
Name: Karl Richter
Company: Laika

Email: ******
City: Portland
Country: United States
Website: www.laika.com
Forum Name:
Platform: WindowsXP 32
Hardware:
3D Package: Maya

>>: Software bugs
>>: I am having a reoccurring problem where realflow crashes when loading a saved scene. This is becoming a real issue, as I have had to rebuild the same scene 5 or 6 times now. Please advise.

Karl


__________ NOD32 2837 (20080130) Information __________

This message was checked by NOD32 antivirus system.
http://www.eset.com


_____________________________________________________________________
The information contained in this message and its attachments is
confidential and proprietary to LAIKA, Inc. By opening this email
or any of its attachments, you agree to keep all such information
confidential and not to use, distribute, disclose or copy any part
of such information without the prior written consent of LAIKA,
Inc. If you are not the intended recipient of this message, any use,
distribution, disclosure or copying of such information is prohibited.
If received in error, please contact the sender.


overload
Posts: 176
Joined: Mon Dec 18, 2006 5:00 pm

scene crashes realflow on load

Postby overload » Fri Feb 01, 2008 6:30 pm

Do you have alot of geometry imported from other packages in your scene? I've had plenty of occurrences where something I imported doesn't agree with RF and it will be find initially, but afterwards the scene files are corrupted. A bad OBJ, FBX (RF doesn't like FBX from what i've tested)... Hope that helps.

Anthony

lukeiamyourfather
Posts: 2880
Joined: Mon Oct 15, 2007 4:09 pm
Contact:

scene crashes realflow on load

Postby lukeiamyourfather » Fri Feb 01, 2008 7:55 pm

What happens when it crashes? Are you on a 32-bit system? How big is the scene file? How big are the objects being imported? What version of RF are you using?

If we can get a clearer image of exactly what's happening, then it's easier to troubleshoot. Honestly though I've never had the problem you speak of. Cheers!

freakyfranck
Posts: 28
Joined: Mon Oct 15, 2007 2:35 pm

scene crashes realflow on load

Postby freakyfranck » Wed Feb 13, 2008 3:01 pm

I think i might have the very same problem...

It occur when i save or i delete something in the nodes panel. Everything freeze and i have no response with realflow. I have to end the process in the task manager. Then when i try to re-open the scene it crash on load. All the incremented versions of this scene are also corrupted. It happen like 3-4 times a week so it's quite frustrating. Maybe its because i am working with a remote desktop. Here is the detail of the situation:

Hardwar detail:

Realflow 32bit version 4.1.1.0091
Window 32 bit
Intel Xeon Dual Quad 2.33ghz with 3gig of ram
Working in remote desktop

Scene detail:

realwave with 2 fractal and 1 spectrum
2 gravity
1 imported camera
1 drag force
1 boat imported in .sd with rigid body (9298 faces)
2 rf cube with rigid body and fixed constraint to the boat
1 rw splash set to inactive

Maybe we have a problem in common, i would be like to see your scene and hardware detail.

shaun_michael
Posts: 4766
Joined: Sun Sep 10, 2006 8:04 am

scene crashes realflow on load

Postby shaun_michael » Wed Feb 13, 2008 5:00 pm

Do you get the same error with an up-to-date version of Realflow. v4.1 is quite a long way behind the times. Download 4.3.8.0123 (32 bit) from the usual place and see what happens.

I dont think I still have release notes that go that far back, and the release notes on RFs download page reference 4.3.6.xxxx but it may even mention the problem/fix in those notes.

Shaun

lukeiamyourfather
Posts: 2880
Joined: Mon Oct 15, 2007 4:09 pm
Contact:

scene crashes realflow on load

Postby lukeiamyourfather » Wed Feb 13, 2008 5:45 pm

freakyfranck wrote: I think i might have the very same problem...

It occur when i save or i delete something in the nodes panel. Everything freeze and i have no response with realflow. I have to end the process in the task manager. Then when i try to re-open the scene it crash on load. All the incremented versions of this scene are also corrupted. It happen like 3-4 times a week so it's quite frustrating. Maybe its because i am working with a remote desktop. Here is the detail of the situation:

Hardwar detail:

Realflow 32bit version 4.1.1.0091
Window 32 bit
Intel Xeon Dual Quad 2.33ghz with 3gig of ram
Working in remote desktop

Scene detail:

realwave with 2 fractal and 1 spectrum
2 gravity
1 imported camera
1 drag force
1 boat imported in .sd with rigid body (9298 faces)
2 rf cube with rigid body and fixed constraint to the boat
1 rw splash set to inactive

Maybe we have a problem in common, i would be like to see your scene and hardware detail.

I would have to agree with Shaun on this one. There have been many changes in RF since 4.1. Also depending on how many particles are loading in, you could be reaching the memory addressing limits of a 32-bit system. Check the PF and memory usage when loading RF and see where it peaks. If it peaks near 2GB this could be the cause for the crash. Any 32-bit Windows platform can only allocate 2GB for applications unless the 3GB switch is enabled on the system. Cheers!

Meald
Posts: 1
Joined: Mon Apr 07, 2008 9:10 am

scene crashes realflow on load

Postby Meald » Mon Apr 07, 2008 9:18 am

I have been working with flw scenes that function fine for simulating, saving incrementally as I go along, only to find that every scene I have saved will crash realflow on load. Not running the sim, just the act of loading the scene will cause the crash.

I had exactly the same problem and found the solution. I traced this problem down to RW_Splash. As soon as I add RW_Splash particles to a scene AND assign some object to it the scene starts to cause RF to crash on load. But if you link the object you assigned to RW_Splash to RealWave RF will no longer crash. In other words RF crashes when tries to load a scene where there are any objects assigned to RW_Splash and not linked to RealWave.

P.S. I'm using RF 4.3.8.0123 64bit on Linux

lanzarredes
Posts: 20
Joined: Wed Jan 17, 2007 10:04 am

scene crashes realflow on load

Postby lanzarredes » Mon Apr 07, 2008 1:49 pm

Hi Karl,

I send you the scene in your last email with the solution. You had not kill daemons in your scenes, so the particle go away far from center of the scene and it makes your scene crash because the particles are generating a memory problem when you are loading the scene. In order to solve your problem with the scenes is very difficult because I don´t know if is necessary more RAM to load all scenes or there is another problem on each one.

Luis Miguel :)


Return to “Realflow bug report”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests