Weird problem with particle "layering".

Discussions about the use of Realflow 2012
barakaS
Posts: 4
Joined: Thu Mar 13, 2014 6:19 pm

Weird problem with particle "layering".

Postby barakaS » Thu Mar 13, 2014 8:07 pm

Hello all,

i am having a problem with the particle "layering".
I created as a test, a box and a circle emitter inside it, emitting particles. Once the box bottom is filled with particles, and then it starts to fill the box i realised
there is a big gap between the particles that fill the bottom and the rest that are being "layered" on top.
I have attatched the below image to clarify how the problem looks.
The circle emitter, and the box settings are as by default.
Any ideas anyone, what might be the problem?

Thank you in advance.
Attachments
viewport.jpg
the gaps depicted.
viewport.jpg (231.19 KiB) Viewed 1528 times


User avatar
Oldcode
Posts: 771
Joined: Thu Nov 03, 2011 11:28 pm

Re: Weird problem with particle "layering".

Postby Oldcode » Thu Mar 13, 2014 10:44 pm

Hi,

Thanks for posting pictures of what you are doing when asking a question, that really helps. :D

First, the gap at the bottom is probably because of Collision Distance. In the properties for your cube, look under Particle Fluid Interactions. Try reducing the collision distance until you get results more to your liking.

As to why the particles are layering like that, I'm not sure. How many particles are in your simulation now? Based on the fluid emitter settings, the particles when not being disturbed by a moving object, are going to want to maintain a certain distance from each other. This effect is really noticeable if you have only a few thousand particles. In your emitter settings, you can try adjusting the V and H Random setting, which should give the particles more randomness and chaos as they settle.

Hope this helps,

Good Luck,
"My sword and my service are yours."

"Then forever remind him of his vow, Knight of the Old Code."

barakaS
Posts: 4
Joined: Thu Mar 13, 2014 6:19 pm

Re: Weird problem with particle "layering".

Postby barakaS » Fri Mar 14, 2014 8:28 am

Hi,

I already had the Collision distance property low and the thing that i realised is that it manages the distance the first layer keeps from the object and not the other particle layers. What finally did the job as you reminded me, was the particle resolution. The higher it is, the smaller the gap.

Thank you Oldcode for your help. :)

User avatar
Oldcode
Posts: 771
Joined: Thu Nov 03, 2011 11:28 pm

Re: Weird problem with particle "layering".

Postby Oldcode » Fri Mar 14, 2014 3:44 pm

Cool! I've found it best to keep the fluid resolution at default and ajust size with the Scale setting.
"My sword and my service are yours."

"Then forever remind him of his vow, Knight of the Old Code."


Return to “Realflow 2012”

Who is online

Users browsing this forum: No registered users and 1 guest