Hyper-threading?

General Discussions about realflow, fluid simulations,...
egas7243
Posts: 3
Joined: Tue Jun 11, 2013 2:26 am

Re: Hyper-threading?

Postby egas7243 » Wed Jun 12, 2013 4:06 pm

Ok, good to know! So Tena:

Since you are the lead developer of this software, and I have already tried what you suggested before, do you have any other ideas as to what this problem could be? How should I know for sure, whether this is a software or hardware issue?


fkfx
Posts: 309
Joined: Wed Apr 11, 2012 11:11 am
Location: Cologne, Germany
Contact:

Re: Hyper-threading?

Postby fkfx » Thu Jun 13, 2013 11:58 am

Did you test both command line and GUI? Also try setting the number of maximum threads to the real amount of CPU cores in your system. Does that change a thing?

Saville
Posts: 1
Joined: Wed Jun 19, 2013 10:36 am

Re: Hyper-threading?

Postby Saville » Wed Jun 19, 2013 10:40 am

Hi,

I was wondering if there was any progress or something else I could try on this? I'm wondering if it's a limit of the demo but I'm having the same problem. My machine is running 2x 8 core Xeon processors (32 threads) and CPU usage is a little over 4 or 5 percent. Is this a limit of the software, or should be making use of all the CPU power?

The CPU is recognised properly in that it picks up that there are 32 thread. It's just simulation time is incredibly slow.

mrzbrush
Posts: 1
Joined: Sun Aug 18, 2013 11:23 am

Re: Hyper-threading?

Postby mrzbrush » Sun Aug 18, 2013 11:28 am

egas7243 wrote:Hi Everyone,

I am having a strange issue. I have two computers. One is a Laptop with a single i7 quad core processor and 16gb of ram. The other is a workstation with dual xeon (e-5-2687w) processors giving me 16-cores/32 threads, and 64gb of ram.

When I run the same scene simulation on both computers. It takes me twice as long to simulate on the workstation as it does the laptop, when in theory it should be 4 times faster. When I look at my task manager on my laptop my processor is being used %100, but my workstation is only using 5-8% of the processor, and %8 of my ram is being used. I have made sure that the max threads option is turned on. I even manually turned it off and typed in the correct amount of threads my computer has and I have the same problem.

Any ideas?


Exactly the same specs with the same problems on the dual xeon E5-2687w ... my i7 laptop run simulation faster than my Xeon workstation which is unbelievably slow in realflow rather disappointing

if anybody have any solution or settings needs to be done please share.

gadied
Posts: 2
Joined: Thu Aug 14, 2014 2:43 pm

Re: Hyper-threading?

Postby gadied » Thu Aug 14, 2014 3:19 pm

the same happened to me, in a empty scene, only a circle generator and a plane as collider, the particular it's generated very slow...but i make a discovery.
I went into Setup and I closed without saving changes. I rebooted and opened the realflow. and ... surprise, fluids generated at a very great speed. I simulated the scene and reset three times and the third was that got slow again.
So what I do before working in RealFlow is enter setup and then after the windows open the first software that I open is the realflow. when it gets slow again has to do the process again.
Anyone have any more effective solution?


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 5 guests