Object emitter - Particle 'explode' and 'pump'

General Discussions about realflow, fluid simulations,...
Post Reply
Posts: 1
Joined: Mon May 02, 2016 6:57 pm

Object emitter - Particle 'explode' and 'pump'

Post by DDC » Mon May 02, 2016 7:21 pm

Hey, I'm new to this software, so please apologize any mistakes I make or describe.

I'm using a Dyverso Object Emitter. I selected multiple faces for my particle emitter and for the sake of error detection it is set to a low viscous liquid (with the desired effect of high viscosity it takes longer for the particles to behave exactly the same wrong way).

First problem: The particles emission is 'pumping'. Particles aren't generated every frame but every 10-20 frames suddenly the initial amount of particles is added on the emission faces (1000 -> 2000 -> 3000). Isn't there a way to make it continuous? Or is that due to the high FPS of 240?
I also experimented with different Min/Max Iterations: https://i.gyazo.com/3e9d9af22b2975246de ... 57248f.png

Second Problem: Particles suddenly explode and travel upwards (middle of the gif). Object stickiness is set to very high (40), but there are also: gravity daemon and 3 wind daemons which force particles in the opposite direction of their travel direction. Deactivating all of them does a minimal change but not the undesired explosion/upwards travel. Desired effect is a constant flowing motion down the object.

Third Problem: Particles disregard the mesh and just fall through. (bottom right of gif) I tested solid outside/shell as volume mode.

Gif: https://i.gyazo.com/64f963ea9738d8779fd ... e1d260.gif

Posts: 164
Joined: Mon Mar 15, 2010 4:36 am

Re: Object emitter - Particle 'explode' and 'pump'

Post by Forester » Wed May 11, 2016 11:19 pm

Ah, a Maya user.....

OK, first of all, the Dyverso Solver is incredibly energetic. It is most suitable for things like ponds and medium-scale waterfalls and such. It is not terribly useful for small objects, objects with a lot of faces, and so forth. Having said that, however, you should know that with the Dyverso Solver, you have the choice of two different particle types. The default particle type is the PDB Particle, which seems to me to be more energetic that the SPH Particle type. So, one thing you could try is to switch particle types within the Dyverso Solver to see if that gives you a better result. (With your Dyverso Domain selected, find the "Domain" tab in the Settings Panel, and the first item you will see is "Particle Type." You can choose either the default "Liquid - PDB", the "Liquid - SPH" or "Dumb Particles" there.)

But, in trying to look at your second picture, it might be that you would be better off using the standard, and much slower SPH Solver for this object.

With regard to your "First Problem", it seems likely that your extremely high FPS is the source of the problem. Is there some special reason that you need such a very high FPS? I tried using the Dyverso Object Emitter on a medium-complex object, with a standard FPS, and got a continuous flow of particles per simulation step, so it does seem that the high FPS setting might be the source of the problem, and a good guess on your part.

Can't comment on the "Second Problem" without knowing more about the nature of your "object." Is there any chance you can show us a simple wireframe view of the object you are working from?

For the third problem, when Dyverso particles fall through a mesh, the typical cause is the Object Cell Size setting. Take a look at the explanation in the Help Documentation. Go to "Help" | Realflow 2015 Documentation | Nodes - Dyverso Fluids | DY - Fluid-Object Interaction. You'll have to experiment with the Cell Size a bit to find the right setting, but making the setting smaller should fix your problem.

If it does not, what I do is to go back to Maya, and add faces in the area of my object that is "leaking" in Realflow. A finer mesh in some areas of the object always helps.
Windows 7 Pro 64 - Realflow (Nov 2017 patched) Standard Version

User avatar
Posts: 1044
Joined: Thu Jul 10, 2008 9:48 am
Location: UK - Stuart Armiger

Re: Object emitter - Particle 'explode' and 'pump'

Post by bitSeq » Fri May 13, 2016 3:45 pm

OK so I would use SPH, it may be slower but will be more accurate.

However, if you must use PBD then try this.

The poping will probably be down to the collision and interaction distance on your object, try reducing them. You can also adjust the distance threshold on the emitter.

The pulsing of the emitter is related to the fps you are using, go back to 30fps and try adjusting the time scale in the Dyverso settings, this will have the same effect as changing the fps, its set to 1 as default, 2 will be faster 0.1 will be slower and so on.

Not sure if this is a bug but it does look like it should be fixed, perhaps it is a shortcoming of the Dyverso engine and that is why the scale value is there instead.

good luck.

Post Reply

Return to “General Discussion”